Subject Error with HTTPClient
From Wolfgang Ciriack <ciriack@ciju.de>
Date Tue, 30 Jul 2019 08:32:20 +0200
Newsgroups xb2net

Hello,
i have updated my app to xb2net 3.7.0 and now i get sometimes this error:
ERROR LOG of "\\SERVER01\Daten\fvwwin\FVWWebserver.EXE" Date: 30.07.2019
07:32:37

Xbase++ version     : Xbase++ (R) Version 1.90.355
Operating system    : Windows Server 2008 06.02 Build 09200
------------------------------------------------------------------------------
oError:args         :
           -> VALTYPE: U VALUE: NIL
           -> VALTYPE: N VALUE: 26
oError:canDefault   : N
oError:canRetry     : N
oError:canSubstitute: J
oError:cargo        : NIL
oError:description  : Parameter hat falschen Typ
oError:filename     :
oError:genCode      :          2
oError:operation    : <U of >[<26>]
oError:osCode       :          0
oError:severity     :          2
oError:subCode      :          3
oError:subSystem    : BASE
oError:thread       :          6
oError:tries        :          0
------------------------------------------------------------------------------
CALLSTACK:
------------------------------------------------------------------------------
Called from XBSOCKET:OPEN(2276)
Called from XBSOCKET:RESET(2258)
Called from XBSOCKET:INIT(2190)
Called from XBHTTPCLIENT:EXECUTE(377)
Called from SENDXML(607)
Called from GETAUFFROMSERVER(117)
Called from TASK_DATENABRUF_FVWMOBIL(63)
Called from (B)STARTETHREAD(942)

the corresponding lines are:

oHttp := xbHTTPClient():new()
oResponse:=oHttp:Execute(script,"POST","xml="+xbEscape(cXmlStr))

were script is:
"http://"+M->cWebServer+":84/xml.cs?"+"wkid="+M->cWkId+"&username="+M->LoginMobUser+"&password="+M->LoginMobPw

With xb2net version 3.6.05 i never see this error.
What can cause it ?

Best regards
Wolfgang

Recent messages in this thread
 
-# Error with HTTPClient (Current message) Wolfgang Ciriack 30-Jul-2019 02:32 am
.-# Re: Error with HTTPClient Boris Borzic <bb> 30-Jul-2019 08:51 am
..\# Re: Error with HTTPClient Wolfgang Ciriack 30-Jul-2019 12:47 pm