Subject Re: XBWININET error
From Danny <> <Danny <>>
Date Mon, 07 Oct 2019 09:14:49 +0100
Newsgroups xb2net

Thank you very much for your answers James and Boris.
Our application is indeed multithreaded, so we will try the xbSocket call.

Kind regards,

Danny.

Boris Borzic <bb> Wrote:

> It looks like the Xb2NET.dll is either not initialized or the DLL has
> been unloaded when the error occurred.
>
> If your app is multithreaded, suggest that you make sure everything is
> properly initialized at program start before starting additional threads.
> You can do this by adding the following call at program start (before any
> threads are started):
>
> xbSocket()
>
> If the error occurred at time that application was terminated, then make
> sure that all threads are properly terminated before application quits.
>
> --
> Best regards,
> Boris Borzic
>
> http://xb2.net
> http://sqlexpress.net
> industrial strength Xbase++ development tools
>
> Danny <> wrote in news:tksseh5oz6k3tee.180920191527@daz17:
>
> > We implemented the XBHTTPClient in our Xbase++ application and some of
> > our users now get a strange error.
> >
> > Part of the errorlog is displayed below :
> >
> > -----------------------------------------------------------------------
> > ------- oError:args :
> > -> VALTYPE: U VALUE: NIL
> > -> VALTYPE: N VALUE: 1
> > oError:canDefault : N
> > oError:canRetry : N
> > oError:canSubstitute: Y
> > oError:cargo : NIL
> > oError:description : Parameter has a wrong data type
> > oError:filename :
> > oError:genCode : 2,00
> > oError:operation : <U of >[<1>]
> > oError:osCode : 0,00
> > oError:severity : 2,00
> > oError:subCode : 3,00
> > oError:subSystem : BASE
> > oError:thread : 1,00
> > oError:tries : 0,00
> >========================================================================
> >======
> > CALLSTACK:
> > -----------------------------------------------------------------------
> > ------- Called from XBWININET:ATTEMPTCONNECT(240)
> > Called from XBHTTPCLIENT:WININETEXEC(603)
> > Called from XBHTTPCLIENT:EXECUTE(366)
> > Called from XB2NET_LOADFROMURL(3708)
>


Recent messages in this thread
 
-# XBWININET error Danny <> 18-Sep-2019 09:27 am
.|# Re: XBWININET error James Loughner 18-Sep-2019 04:07 pm
.-# Re: XBWININET error Boris Borzic <bb> 19-Sep-2019 12:16 pm
..\# Re: XBWININET error (Current message) Danny <> 07-Oct-2019 04:14 am