Subject Re: HTTPS and a proxyserver
From Boris Borzic <.> <Boris Borzic <.>>
Date Fri, 30 Apr 2021 22:48:40 -0400
Newsgroups xb2net

Frans Vermeulen <fv@gbor.nl> wrote in
news:20210430102126.763a62542042ab80fcefe2b8@gbor.nl:

> In order to reproduce the problem, I set up a scenario using
> freeproxy (http://handcraftedsoftware.org)
>
> client (xb2net)
>   |
> Freeproxy
>   |
> Server (xb2net)
>
> Using this scenario, I get the same results.
> freeproxy logs no traffic, the only way to see the correct route via
> the proxy is chosen, is monitoring the network traffic with wireshark,
> c.q. netstat -a. No traffic reaches the server.

I would need to replicate this. Can you send me instructions + minimal test
program to reproduce the issue.

In the meantime, try using WinInet. Make sure the proxy settings are
defined in Windows (Internet Explorer)

oHttp := xbHTTPClient():new()
oHttp:Transport == VIA_WININET
oResponse := oHttp:Execute("http://www.website.com")


--
Best regards,
Boris Borzic

http://xb2.net
http://sqlexpress.net
industrial strength Xbase++ development tools

Recent messages in this thread
 
-# HTTPS and a proxyserver Frans Vermeulen 29-Apr-2021 11:19 am
.-# Re: HTTPS and a proxyserver Boris Borzic <.> 29-Apr-2021 04:56 pm
..-# Re: HTTPS and a proxyserver Frans Vermeulen 30-Apr-2021 04:21 am
...-# Re: HTTPS and a proxyserver (Current message) Boris Borzic <.> 30-Apr-2021 10:48 pm
....-# Re: HTTPS and a proxyserver Frans Vermeulen 03-May-2021 04:58 am
.....\# Re: HTTPS and a proxyserver Boris Borzic <.> 03-May-2021 07:36 pm