Subject Error keeps popping up
From Martin Altmann <altmann@altem.de>
Date Tue, 13 Jul 2021 13:49:17 +0200
Newsgroups xb2net

Boris,
I am using version 4.1 and am getting those errors again and again:

______ Xb2.NET ERROR __________ Port: 80 ________________
Date: 13/07/2021, Time: 13:33:22
App: C:\easydog\Easydog-Server.exe, Thread: 8
WinSock error: 336150819 - Error code (336150819)
Called from __DISPERROR(86)
Called from XBHTTPTHREAD:RECV(4590)
Called from XBHTTPMESSAGE:RECV(6155)
Called from XBHTTPTHREAD:EXECUTE(5349)

Any idea what might be the reason? As I am not having the source code of
Xb2.NET I am not able to check it.
Whenever anybody is doing a http-request, a https-redirect is done
automatically (inside the filterrequest by returning a 301 as StatusCode
and setting the location to the corresponding https-address):
if MEMVAR->lForceHttps  .and. !empty( cHost ) .and. !oClient:isSecure()
   oClient:HTTPResponse:StatusCode := 301
   oClient:HTTPResponse:Location("https://" + cHost +
oClient:HTTPRequest:xbURI:AsString(.T.))
   Return .F.
endif

Best regards,
Martin

--
______________________________

Deutschsprachiges Xbase-Forum:
http://www.xbaseforum.de/
______________________________

Recent messages in this thread
 
-# Error keeps popping up (Current message) Martin Altmann 13-Jul-2021 07:49 am
.-# Re: Error keeps popping up Boris Borzic <.> 13-Jul-2021 05:26 pm
..-# Re: Error keeps popping up Martin Altmann 14-Jul-2021 02:13 am
...-# Re: Error keeps popping up Boris Borzic <.> 14-Jul-2021 10:56 am
....\# Re: Error keeps popping up Martin Altmann 14-Jul-2021 03:23 pm